Skip to main content.
home | support | download

Back to List Archive

Re: [swish-e] SWISH::Filter module not found

From: Peter Karman <peter(at)not-real.peknet.com>
Date: Wed Oct 27 2010 - 04:09:36 GMT
Troy Wical wrote on 10/26/10 11:06 PM:
> Thanks for that. It's not the first time you've mentioned to me the issues of having modules installed from different areas. I edited spider.pl to point to the CPAN version and the errors are no more. I do get the following now though after it runs for a couple minutes, I believe it is not due to the page that is being crawled. Though, I've been wrong before.
> 
> #############################################
> Warning: Unknown header line: 'ath-Name: http://type2.com/ezmlm-archives/index.cgi?list=type2&cmd=monthbydate&month=201009' from program spider.pl
> err: External program failed to return required headers Path-Name:
> #############################################
> 

that sounds like an encoding issue. The problem happens when the length reported
in the previous document != the actual document length, and the leading 'P' gets
read as part of the previous document.

Turn on the spider.pl debugging verbosity to see each URL, and check the
accuracy of the encoding and document length of the URI *before*

http://type2.com/ezmlm-archives/index.cgi?list=type2&cmd=monthbydate&month=201009



-- 
Peter Karman  .  http://peknet.com/  .  peter(at)not-real.peknet.com
_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users
Received on Wed Oct 27 00:09:37 2010