Skip to main content.
home | support | download

Back to List Archive

Re: [swish-e] Search.cgi error

From: Peter Karman <peter(at)not-real.peknet.com>
Date: Thu Aug 14 2008 - 02:30:12 GMT
Cutts III, James H. wrote on 7/25/08 11:25 AM:
> I am working my way through the process getting Swish-e to work on my
> Windows XP /IIS 5.1 setup. I've made pretty good progress.
> 
> I can run Swish-e (V.2.4.5) to index the files. 
> I can run Swish-e from the command line to query the files.
> I can access Swish-e through the Perl API.
> I can run Perl scripts in IIS server.
> I have renamed search.cgi to search.pl.
> I can run search.pl from the command line and it generates the search
> page html.
> I can run search.pl from the web server and it generates the search
> page.
> 
> However, if I make a query to the web page, I get the following error:
> "undef error - Unknown property name in display properties Invalid
> property name 'swishdescription' at C:/Perl/site/lib/Template/Stash.pm
> line 453."
> 
> I can get this error when running from the command line if I set the
> $request->{query} = <a search word> in the search.pl file.
> 
> Are there any suggestions on how to eliminate this error?

sorry to miss this for so long.

Did you try adding:

  StoreDescription HTML* <body>

to your config and re-indexing? See the StoreDescription section of the 
SWISH-CONFIG doc.

-- 
Peter Karman  .  http://peknet.com/  .  peter(at)not-real.peknet.com
_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users
Received on Wed Aug 13 22:30:10 2008