Skip to main content.
home | support | download

Back to List Archive

[swish-e] Indexing via HTTPS - Not Working

From: Adam Douglas <ADouglas(at)not-real.venmarces.com>
Date: Thu Feb 21 2008 - 19:19:44 GMT
When I try to index using https I receive the following error message. 

#swish-e -S prog -c swishe.venmarces.private.conf
Password:
Indexing Data Source: "External-Program"
Indexing "/usr/local/lib/swish-e/spider.pl"
External Program found: /usr/local/lib/swish-e/spider.pl
/usr/local/lib/swish-e/spider.pl: Reading parameters from
'SwishSpiderConfig.pl'

 -- Starting to spider:
https://blowfish.venmarces.com/login/?szID=username&szPWD=password --
?Testing 'test_url' user supplied function #1
'https://blowfish.venmarces.com/login/?szID=username&szPWD=password'
+Passed all 1 tests for 'test_url' user supplied function

vvvvvvvvvvvvvvvv HEADERS for
https://blowfish.venmarces.com/login/?szID=username&szPWD=password
vvvvvvvvvvvvvvvvvvvvv

---- Request ------
GET https://blowfish.venmarces.com/login/?szID=username&szPWD=password
Accept-Encoding: gzip, x-gzip, deflate
From: webmaster@venmarces.com
User-Agent: swish-e spider http://swish-e.org/


---- Response ---
Status: 500 Can't locate object method "new" via package
"LWP::Protocol::https::Socket"
Content-Type: text/plain
Client-Date: Thu, 21 Feb 2008 18:53:06 GMT
Client-Warning: Internal response

^^^^^^^^^^^^^^^ END HEADERS ^^^^^^^^^^^^^^^^^^^^^^^^^^


Summary for:
https://blowfish.venmarces.com/login/?szID=username&szPWD=password
Connection: Close: 1  (1.0/sec)
      Unique URLs: 1  (1.0/sec)

Removing very common words...
no words removed.
Writing main index...
err: No unique words indexed!

I'm not sure what to do to resolve this error. As I have tried to
install the modules thinking they were not. When I tried to install
LWP::Protocol::https::Socket and I receieve "Cannot install
LWP::Protocol::https::Socket, don't know what it is.". Then I tried
"LWP::Protocol" and "LWP::Protocol::https" and I received "is up to
date" fore each one. By the way when I list what Perl modules are
installed I only see the following modules.

Installed modules are:
   Compress::Raw::Zlib
   Compress::Zlib
   Devel::Symdump
   Digest::MD5
   HTML::Parser
   HTML::Tagset
   IO::Compress::Base
   IO::Compress::Zlib
   IO::Stringy
   LWP
   MIME::Base64
   MIME::Types
   OLE::Storage_Lite
   Perl
   Pod::Coverage
   Pod::Escapes
   Pod::Simple
   Spreadsheet::ParseExcel
   Test::Pod
   Test::Pod::Coverage
   Test::Simple
   URI

I tried to get some help in IRC in the Perl channel on freenode and I
receive this response "just 'use LWP::Protocol::https;'
LWP::Protocol::https::Socket isn't in its own file.". Being of course
since I did not write Swish-e I'm now lost further as to how to resolve
the issue of indexing via https. I receive no error messages when
indexing via http.

Best,
Adam

This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed and may contain information that is non-public, proprietary,privileged, confidential, and exempt from disclosure under applicable law or may constitute as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this communication in error, notify us immediately by telephone and
(i) destroy this message if a facsimile or (ii) delete this message
immediately if this is an electronic communication. Thank you.
_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users
Received on Thu Feb 21 14:19:44 2008