Skip to main content.
home | support | download

Back to List Archive

[swish-e] swish-e 2.4.5 on RHEL3: spider.pl perl module problem

From: Guy Waugh <guy.waugh(at)not-real.scu.edu.au>
Date: Tue Apr 17 2007 - 01:35:09 GMT
Hello,

I've just compiled swish-e on an RHEL3 server and I'm trying to use
spider.pl to index a website. I've installed swish-e in
/usr/local/inst/www/swish-e-2.4.5.

When I cd to the /usr/local/inst/www/swish-e-2.4.5/lib/swish-e directory
and run './spider.pl default http://<url.to.index>/', it says this:

No SWISH filters found
./spider.pl: Reading parameters from 'default'
Can't locate object method "decoded_content" via package "HTTP::Headers"
at (eval 20) line 1.

Summary for: http://<url.to.index>/
Connection: Close: 1  (1.0/sec)
      Unique URLs: 1  (1.0/sec)

Looks like it's missing a perl module, but I don't know which one... I
have the following perl packages installed on the system:

perl-libwww-perl-5.65-6
perl-XML-Grove-0.46alpha-25
perl-DateManip-5.42a-0.rhel3
perl-5.8.0-94.EL3
perl-XML-Parser-2.31-16.EL3
perl-Filter-1.29-3
perl-DBI-1.32-9
perl-URI-1.21-7
perl-Parse-Yapp-1.05-30
perl-HTML-Parser-3.26-17
perl-libxml-perl-0.07-28
perl-libxml-enno-1.02-29
perl-XML-Twig-3.09-3
perl-DBD-MySQL-2.1021-4.EL3
perl-HTML-Tagset-3.03-28
perl-XML-Encoding-1.01-23
perl-XML-Dumper-0.4-25
perl-CGI-2.89-94.EL3
perl-Crypt-SSLeay-0.51-4

I haven't done much with perl before, but it appears that the LWP stuff
is in the perl-libwww-perl package(?).

Any ideas which perl module I need to install, or could it be something
else?

Thanks,
Guy.


_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users
Received on Mon Apr 16 21:35:07 2007