Skip to main content.
home | support | download

Back to List Archive

Re: SWISH-e 2.4.4 RPMs for Fedora Core 6

From: David L Norris <dave(at)not-real.webaugur.com>
Date: Thu Jan 11 2007 - 20:01:19 GMT
On Thu, 2007-01-11 at 11:49 -0800, Simon A Wilper wrote:
> Right now I have two packages for SWISH-e itself and the Perl-API Module
> "SWISH::API" since SWISH-e is a build requirement for the Perl-API.
> 
> Do you think this split-up is reasonable?  Or shall I bundle this into
> one package?

I think it makes sense to split out SWISH::API since its unbundled from
swish-e.  

I also think the other Perl-related bits should be in separate packages.
There is an old RPM spec file in swish-e/rpm/swish-e.spec.in which is
divided into a number of packages.  Its probably useless in itself but
its an example of my thinking in FC3.  My main problem with maintaining
Fedora RPMs was the lack of CPAN modules provided by Fedora.  swish-e
always ended up with 30 perl dependencies that couldn't easily be
fulfilled by RPMs.  Maybe that situation is better now?

-- 
 David L Norris
  http://webaugur.com/
  ICQ - 412039
Received on Thu Jan 11 12:01:20 2007