Skip to main content.
home | support | download

Back to List Archive

Re: User-Agent: Mozilla/2.0 and Mozilla/5.0 (compatible

From: Bill Moseley <moseley(at)>
Date: Wed Jan 10 2007 - 16:44:28 GMT
On Wed, Jan 10, 2007 at 08:05:37AM -0800, James wrote:
> Where is the abrasiveness?  I have been polite.  I am not demanding
> anything.  I am simply asking questions, trying to get a better
> understanding of Swish-e, so that either A) I can make needed changes,
> or B) I can pay someone to come up with a solution for me.

Ok, troll or not, let's review for the archives.  We can point the
docs to this as an example of how not to ask a question.

James asks:
    Is it possible to tweak the Swish-e spider so that it will follow
    image-based links, even if the image does not have an alt tag?

    Are you sure about that?  Did you test before posting?

James insists:
    Yes, I am sure about it.  I have been testing several sites for a
    couple weeks. This seems to be an issue, definitely.
    ...Obviously, I would test before posting...

    Then you can provide an example so we don't have to guess
    what might not be working in your case?

    It would be most helpful if you provided an example of the
    HTML that is not behaving the way you expect it to.

James demands:
    Set-up an HTML page, such as your main index page, with an image
    based link into the rest of the site, with no alt tag and you have
    your example.  Swish-e won't follow it.  So, what I am asking is,
    how can the spider code be tweaked to get it to follow the link
    that is actually in the HTML.

    that's not an example. that's just more description.

    Show your work.  (with a pointer to a link explaining how to
    to correctly ask a question on the list and provide a working

    Here's an example of the code:

    <a href="" target="_self"><img
    src="images/entersite.gif" alt="" width="129" height="15" border="0"

    That's the best I can do.  Swish-e won't follow that.

    Look, you claim that the spider isn't following a link.  Support
    your claim with an example that shows the problem.  You are just
    wasting my time now.

    In response to: "That's the best I can do.  Swish-e won't follow

    Right.  You can't come up with a working example like the
    docs I pointed to you suggest?  Don't you have a web server?  Oh,
    you don't even need one:

    <complete working example demonstrated>

    I responded with simply the code, since Peter said that I didn't
    need to provide a link.  So, you're just being downright rude.  Of
    course I have a web-server.

    (regarding posted working example, demands:)

    Why don't you test this on a real server.  By the way, you are a
    filthy man.  That's terribly unprofessional of you.  Here you have
    an open source project on a university site and you are being
    filthy and unprofessional.

Now where did I put that kill file?

Bill Moseley

Unsubscribe from or help with the swish-e list:

Help with Swish-e:
Received on Wed Jan 10 08:44:32 2007