Skip to main content.
home | support | download

Back to List Archive

CGI trouble with swish-e

From: Lewis Foster <doof205(at)not-real.gmail.com>
Date: Wed May 24 2006 - 10:52:49 GMT
I'm pretty new to the world of Linux and swish-e. I have managed to get
swish installed and it happily indexes files, even pdfs but something is
amiss with my search CGI.

Using the CGI bundled with swish I get the following error when I direct my
browser to it:

Name "Template::ERROR" used only once: possible typo at
/opt/www0/apache/rancor.cambridge.com/cgi-bin/ksearch/search.cgi line 286.

Can't locate object method "new" via package "Template" at
/opt/www0/apache/rancor.cambridge.com/cgi-bin/ksearch/search.cgi line 285.

[Wed May 24 11:32:27 2006] [error] [client 134.32.103.57] Premature end of
script headers:
/opt/www0/apache/rancor.cambridge.com/cgi-bin/ksearch/search.cgi

The first one isn't really an issue. But the second certainly is.

Using activeperl I have installed "template", "HTML-Template" and various
others I was missing.

Also, where and what is the SWISH::API?...I cant find it on CPAN or my PPM
respositories, im not aware of having installed it so maybe this is the
problem?

Thanks for your time and any help you can offer.

Lewis



*********************************************************************
Due to deletion of content types excluded from this list by policy,
this multipart message was reduced to a single part, and from there
to a plain text message.
*********************************************************************
Received on Wed May 24 03:53:00 2006