Skip to main content.
home | support | download

Back to List Archive

2.4.3 Refuses to Index Virtual Host

From: fh oregon <linux(at)not-real.frankhunt.com>
Date: Fri Apr 08 2005 - 23:32:27 GMT
Hi -
Indexing refuses to traverse and index the directories associated with
the second web site in a virtual host environment.  Site contains a
total of 5233 pages, 1322 of which are in the virtual site tree.
 


Ver: SWISH-E 2.4.3
RH_Linux: 9.0
Apache: 2.0.40
 


Web site uses virtual hosting to cover:
Personal: mysite.com and
Car Club: carclub.com
 


mysite.com is the primary site.  The car club URL points to a directory
tree in the main site's root:
 


/web/httpd/htdocs = root of mysite.com
/web/httpd/htdocs/CARS = root of carclub.com
 


ALMOST NOTHING in the /CARS tree is indexed (like 5 out of 1333 pages)
 


More Details - - - -
 


   swish.conf:
   IndexDir spider.pl
   SwishProgParameters default http://mysite.com/
   Metanames swishtitle swishdocpath
   StoreDescription TXT* 10000
   StoreDescription HTML* <body> 10000
   IndexFile ./mysite.com.index
   IndexReport 2
 

Indexing Command:
   /usr/local/bin/swish-e -S prog -c /web/httpd/conf/web_index/swish.conf
 


I have eliminated indexing of all other directories via robots.txt -
/CARS is the only one that is not "Disallowed" yet still no indexing.

I am a newbie to swish-e, so there is probably something I am not
looking at (I hope).
Could this be an Apache config problem?  Phase of the moon?  Bad luck?
 


Any ideas????

-- 
Frank Hunt
Confused Linux Admin
Received on Fri Apr 8 16:32:37 2005