Skip to main content.
home | support | download

Back to List Archive

SWISH-E 2.4.0-pr1 -- spider.pl ain't working

From: Bill Conlon <bill(at)not-real.tothept.com>
Date: Thu Aug 21 2003 - 18:09:35 GMT
Downloaded latest build this morning.  Installed on Redhat 9 (up to date 
with patches).

Everything goes swimmingly until I try to use the spider:

# swish-e -S prog -c spider.config
Indexing Data Source: "External-Program"
Indexing "spider.pl"
Unquoted string "cd" may clash with future reserved word at 
/usr/local/lib/swish-e/perl/SWISH/Filter.pm line 1.
Unquoted string "data" may clash with future reserved word at 
/usr/local/lib/swish-e/perl/SWISH/Filter.pm line 1.
Useless use of division (/) in void context at 
/usr/local/lib/swish-e/perl/SWISH/Filter.pm line 1.
Argument "\x{64}\x{61}..." isn't numeric in division (/) at 
/usr/local/lib/swish-e/perl/SWISH/Filter.pm line 1.
Argument "\x{63}\x{64}" isn't numeric in division (/) at 
/usr/local/lib/swish-e/perl/SWISH/Filter.pm line 1.
Failed to find the SWISH::Filter module
/usr/local/lib/swish-e/spider.pl: Reading parameters from 'default'

Warning: Unknown header line: '>Path-Name: 
http://www3.tothept.com/people/' from program spider.pl
err: External program failed to return required headers Path-Name:

Here is spider.config 

IndexDir spider.pl
SwishProgParameters default http://www3.tothept.com/index.html

I read the thread about encoding, but that's not it.  I get the same or 
similar errors indexing 

www3.tothept.com (apache2.047)
www.tothept.com (AppleShareIP 6.3.3)
swish-e.org (apache 1.3.26)

Any suggestions?

Bill Conlon

To the Point
345 California Avenue Suite 2
Palo Alto, CA 94306

office: 650.327.2175
fax:    650.329.8335
mobile: 650.906.9929
e-mail: mailto:bill@tothept.com
web:    http://www.tothept.com
Received on Thu Aug 21 18:13:51 2003