Skip to main content.
home | support | download

Back to List Archive

Swish-e depth

From: Thomas McDonald <tom.mcdonald(at)>
Date: Wed Feb 19 2003 - 14:00:32 GMT
Swish doesn't seem to be indexing my whole site.  I read the config file
instructions and it says:

MaxDepth defines how many links the spider should follow before stopping. A
value of 0 configures the spider to traverse all links. The default is
MaxDepth 5.

So I set the depth to 0 (you can see my config below), but when I searched
the index for keywords that should get hits on a particular deep page I find
that the deep page is not in the results.  For example, I searched for the
'accumulation' keyword and I didn't get the 'accumulation tool' page.

Please feel free to index our site if you want to try it.  It is a public
site.  The page link is right there on the site map, but it doesn't get

Could it have something to do with the long length of this url?  Or maybe
because it is a dynamic url?

I have run the index several times with different depths.  I started at 5
and worked my way down.  Could it be that Swish-e isn't updating my index
file?  The date on the file changes every time I rerun the index command.
Here is the index command:

swish-e.exe -c ex.config -S http

Here is my config file (ex.config)

IndexFile wsl_test.index
DefaultContents HTML
StoreDescription HTML <body> 20000


Thomas McDonald
Title: Principal Consultant
Sogeti USA
4445 Lake Forest Drive
Suite 550
Cincinnati, OH 45242

Due to deletion of content types excluded from this list by policy,
this multipart message was reduced to a single part, and from there
to a plain text message.
Received on Wed Feb 19 14:01:20 2003