Skip to main content.
home | support | download

Back to List Archive

Can't locate TemplateDefault.pm

From: Jody Cleveland <Cleveland(at)not-real.mail.winnefox.org>
Date: Tue Feb 11 2003 - 21:31:15 GMT
Hello,

Well, I got a brand new redhat 8 server, and I'm once again having problems
setting swish up.

When I run:
./swish.cgi from a command line, I get:

./swish.cgi Can't locate TemplateDefault.pm in @INC (@INC contains: modules
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at
./swish.cgi line 738.

Content-Type: text/html

<html>
<head><title>Software Error</title></head>
<body><h2>Software Error</h2><p>Please check error log</p></body>
</html>

So, I followed Bill's instructions from a previous email:
> No you are telling it to use Template Toolkit.  So that needs to be
installed.

> You can get it from these places if you install modules manually (which is
> what I do - perl Makefile.PL && make && make test && make install)
   http://search.cpan.org/author/ABW/Template-Toolkit-2.08/

So, I did that, but I get the same error message when trying to run
./swish.cgi

Am I missing something? And, I was looking through the log files, and
couldn't figure out which one I should be looking at.

Thanks in advance for your help.


--
Jody Cleveland
(cleveland@mail.winnefox.org) 

Help Microsoft stamp out piracy - give Linux to a friend today
Received on Tue Feb 11 21:32:01 2003