Skip to main content.
home | support | download

Back to List Archive

Re: Bad links in documentation

From: Bill Moseley <moseley(at)not-real.hank.org>
Date: Wed Jan 15 2003 - 17:23:49 GMT
On Wed, 15 Jan 2003, Greg Fenton wrote:

> Bill,
> 
> There are a couple of bad links in the FAQ Doc on the SWISH-E website.

Yes, I know.  I haven't had the chance to look at them yet.  

The docs are auto-built from .pod files.  It makes mistakes, but also some
of the links are not specified correctly.  I've been meaing to move to
Stas Bekman's DocSet package and use to built the entire swish-e site.
One of these days...

> 
> Go to:
> 
> http://www.swish-e.org/current/docs/SWISH-FAQ.html#How_do_I_modify_the_path_or_URL_of_the_indexed_documents_
> 
> Once there, the link to "ReplaceRules" at the does not link to the
> CONFIG doc.  It currently is:
> 
>   <a HREF="#item_ReplaceRules">
> 
> But I think it should be
> 
>   <a HREF="SWISH-CONFIG.html#item_ReplaceRules">
> 
> (this is line 1051 in SWISH-FAQ.html)
> 
> 
> This problem appears to exist in many places in the FAQ.  If you search
> for "#item_" in SWISH-FAQ.html, you should see the same pattern as the
> ReplaceRules issue above.
> 
> Lastly, there is a link to "#item_examples" in the FAQ.  I could not
> find an "item_examples" in any of the docs, so I don't know where that
> should be linking to.
> 
> I don't know how the docs are generated.  If they are hand-done, I'd be
> happy to make mods and return them to you.  If they are generated from
> some other source (DocBook or something), I could do the work but I may
> need a pointer or two.
> 
> Hope this helps,
> greg_fenton.
> 
> =====
> Greg Fenton
> greg_fenton@yahoo.com
> 
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com
> 
> 

-- 
Bill Moseley moseley@hank.org
Received on Wed Jan 15 17:24:03 2003