Skip to main content.
home | support | download

Back to List Archive

Error trying to build perl module

From: Jeff St. Laurent <JStlau(at)not-real.ci.scarborough.me.us>
Date: Tue Nov 12 2002 - 12:52:04 GMT
Hi,
 
Trying to build the perl module and get the following error:
 
Swish was built with zlib support
Swish was built with libxml2 support
MakeMaker (v5.4302)
        DIR => []
        LIBS => [q[-L../src -lswish-e -lz -lxml2]]
        NAME => q[SWISHE]
        NORECURS => q[1]
        PREREQ_PM => {  }
        VERSION_FROM => q[SWISHE.pm]
Using PERL=/usr/bin/perl
Potential libraries are '-L../src -lswish-e -lz -lxml2':
Warning: -L../src changed to -L/usr/local/swish-e-2.2.1/perl/../src
'-lswish-e' found at /usr/local/swish-e-2.2.1/perl/../src/libswish-e.a
z not found in /usr/local/swish-e-2.2.1/perl/../src
'-lz' found at /lib/libz.so.1
xml2 not found in /usr/local/swish-e-2.2.1/perl/../src
xml2 not found in /lib
xml2 not found in /usr/lib
xml2 not found in /usr/ccs/lib
Note (probably harmless): No library found for -lxml2
Writing Makefile for SWISHE
schoolproxy# make
cc -c   -xO3 -xdepend    -DVERSION=\"0.02\" -DXS_VERSION=\"0.02\" -KPIC
-I/usr/perl5/5.00503/sun4-solaris/CORE  SWISHE.c
make: cc: Command not found
make: *** [SWISHE.o] Error 127
 
 
Any help would be much appreciated.
 
Jeff St. Laurent
jstlau@ci.scarborough.me.us
Received on Tue Nov 12 12:52:47 2002