Skip to main content.
home | support | download

Back to List Archive

Library requirement for Swish-e

From: Bill Moseley <moseley(at)not-real.hank.org>
Date: Tue Sep 04 2001 - 13:04:56 GMT
In a week or so I'll be testing swish with a library called libxml2.  It's
a parser, like Expat, but it also parses HTML.  libxml2 is a separate
library, and will require installation before building swish-e.  libxml2 is
well supported and is quickly becoming a standard (will probably be a
standard library on Linux, soon).  There are binary ports available.

If you are using the development code, then sometime in the next few weeks
you might want to get libxml2 installed.  It was a very simple installation
process on my machine.

Info on libxml2 can be found at http://www.xmlsoft.org/.

The new XML parser will be a bit more strict than the old XML parser which
allowed not well formed XML to be parsed.

Also, one form of meta tags that's listed in the documentation will not work:

    <!-- META START NAME="meta1" -->
        some content
    <!-- META END -->

I doubt anyone uses that, as, IIRC, it was broken in previous versions anyway.



Bill Moseley
mailto:moseley@hank.org
Received on Tue Sep 4 13:09:08 2001