Skip to main content.
home | support | download

Back to List Archive

Re: Searching for a phrase...

From: FISHER,JOSEPH (Non-HP-Roseville,ex1) <joseph_fisher(at)not-real.non.hp.com>
Date: Wed Aug 15 2001 - 19:54:57 GMT
Hi Bill,

I should say that; my HTML-based search engine in working as it's supposed
to... Except that it doesn't work with "enclosed phrases"...

On the other hand, my command line search doesn't seem to be working at
all... That's not really a problem for me, as ALL of my users will use the
HTML interface...

Here's a copy of my command line output:

--> ../swish-e/swish-e -w '"Contract Role"' -f ./WFM.indx

# SWISH format 1.3
# Swish-e format 1.3
#
# Name: Improvement index
# Saved as: WFM.indx
# Counts: 63655 words, 8617 files
# Indexed on: 10/08/01 11:46:14 PDT
# Description: This is an index to test bug fixes in swish.
# Pointer: http://sunsite/~ghill/swish/index.html
# Maintained by: Jim Brannan, (jim_brannan@hp.com)
# DocumentProperties: Enabled
# Stemming Applied: 0
# Search words: "contract role"
err: no results
.

Again, if I execute the search from the HTML document, I get 92 documents
found, but only 1 or 2 actually have the "Contract Role" phrase in them...
All of the rest have the words "Contract" and "Role", just not together...

So, in clarifying my request for assistance, I need to know which
HTML-related files might contain the phrase delimiter...

One other concern...

In Unix, characters are Case Sensitive...

Are characters Case Sensitive in SWISH-E?

Notice that I typed: "Contract Role", but the search words noted by the
system were "contract role"... All lower case...

Final concern...

I tried a different "phrase" search, using the following phrase: "retrieval
slow when using"...

--> ../swish-e/swish-e -w '"retrieval slow when using"' -f ./WFM.indx
# SWISH format 1.3
# Swish-e format 1.3
#
# Name: Improvement index
# Saved as: WFM.indx
# Counts: 63655 words, 8617 files
# Indexed on: 10/08/01 11:46:14 PDT
# Description: This is an index to test bug fixes in swish.
# Pointer: http://sunsite/~ghill/swish/index.html
# Maintained by: Jim Brannan, (jim_brannan@hp.com)
# DocumentProperties: Enabled
# Stemming Applied: 0
# Search words: "retrieval slow using"
err: no results
.

Notice that the word "when" was ommitted from the search string... I typed
"retrieval slow when using", but the search engine only shows "retrieval
slow using"... This is NOT an exact match...

When using quotes, the search engine should NOT remove un-indexed words...
(I'm assuming that the word "when" is one of the default words to ignore
when indexing...)

Thanks in advance, and have a great day...

Joe Fisher

-----Original Message-----
From: Bill Moseley [mailto:moseley@hank.org]
Sent: Wednesday, August 15, 2001 09:59
To: Multiple recipients of list
Subject: [SWISH-E] Re: Searching for a phrase...


At 09:49 AM 08/15/01 -0700, FISHER,JOSEPH (Non-HP-Roseville,ex1) wrote:
>I have SWISH-E completely setup, and the search engine is working just
>fine...

Please send an example of a single file, and a simple indexing example, and
a search that is not working like you think it is.  If we can't reproduce
what you are doing then we cannot help.

cut-n-paste *everything* into the mail you send so we can see exactly what
you are doing.  You don't need a complicate config file -- you probably
don't need one at all for this problem:

Index:
 ./swish-e -i test.file

Search:
 ./swish-e -w '"this is a phrase"'





See 
http://sunsite.berkeley.edu:4444/INSTALL.html#QUESTIONS_AND_TROUBLESHOOTING




Bill Moseley
mailto:moseley@hank.org
Received on Wed Aug 15 19:55:25 2001