Skip to main content.
home | support | download

Back to List Archive

Re: Errors during HP-UX install of 2.1

From: Bill Moseley <moseley(at)not-real.hank.org>
Date: Fri Aug 03 2001 - 14:22:40 GMT
At 04:00 PM 08/02/01 -0700, FISHER,JOSEPH (Non-HP-Roseville,ex1) wrote:
>I'm getting the following warnings and errors, while attempting to run the
>make command on an HP-UX server, running HP-UX 11.X:

Check out http://hpux.cs.utah.edu/

There you can install packages (GNU binutils and gcc) which will make life
more enjoyable!

I was just looking at libxml2 (I've replaced swish's XML parser with Expat,
and I'm not looking to replace the HTML parser - libxml2 does both!) but it
says this:

  libxml does not compile with HP-UX's optional ANSI-C compiler 
  this is due to macro limitations. 
  Try to add " -Wp,-H16800 -Ae" to the CFLAGS
  you can also install and use gcc instead or use a precompiled 
  version of libxml, both available from the HP-UX Porting 
  and Archive Centre http://hpux.cae.wisc.edu/hppd/auto/summary_all.html

I see so much of this kind of thing that I think that you will be better
off with gcc, if possible.



Bill Moseley
mailto:moseley@hank.org
Received on Fri Aug 3 14:23:01 2001